import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?<=\\<span class=\\\"highlight highlight--wrapping\\\"\\>)(.*?)(?=\\<\\/span\\>)";
final String string = "<div>... <span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span> (David Cantwell for Forbes) \n\n"
+ "On a cool summer afternoon at Dublin's Heuston Station, <span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span>, 81...<br> slowly limped out of the station completely unnoticed. And that's just how <span class=\"highlight highlight--wrapping\">Feeney</span> likes it.\n"
+ "<span class=\"highlight highlight--wrapping\">Chuck</span> <span class=\"highlight highlight--wrapping\">Feeney</span> is the James ...</div>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}