re = /(?m)^\|\={3}[\r\n]([\s\S]+?(?=^\|\={3}[\r\n]))^\|={3}[\r\n]/m
str = '
[cols="1,1"]
|===
|Cell in column 1, row 1
|Cell in column 2, row 1
|Cell in column 1, row 2
|Cell in column 2, row 2
|Cell in column 1, row 3
|Cell in column 2, row 3
|===
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end