#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^\|\={3}[\r\n]([\s\S]+?(?=^\|\={3}[\r\n]))^\|={3}[\r\n]"
Local $sString = "" & @CRLF & _
"[cols="1,1"]" & @CRLF & _
"|===" & @CRLF & _
"|Cell in column 1, row 1" & @CRLF & _
"|Cell in column 2, row 1" & @CRLF & _
"" & @CRLF & _
"|Cell in column 1, row 2" & @CRLF & _
"|Cell in column 2, row 2" & @CRLF & _
"" & @CRLF & _
"|Cell in column 1, row 3" & @CRLF & _
"|Cell in column 2, row 3" & @CRLF & _
"|===" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")