import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^\\|\\={3}[\\r\\n]([\\s\\S]+?(?=^\\|\\={3}[\\r\\n]))^\\|={3}[\\r\\n]";
final String string = "\n"
+ "[cols=\"1,1\"]\n"
+ "|===\n"
+ "|Cell in column 1, row 1\n"
+ "|Cell in column 2, row 1\n\n"
+ "|Cell in column 1, row 2\n"
+ "|Cell in column 2, row 2\n\n"
+ "|Cell in column 1, row 3\n"
+ "|Cell in column 2, row 3\n"
+ "|===\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}