$re = '/CREATE INDEX (.*)|CREATE CLUSTERED INDEX (.*)|CREATE NONCLUSTERED INDEX (.*)/m';
$str = 'CREATE INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]
CREATE CLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]
CREATE NONCLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);