#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)CREATE INDEX (.*)|CREATE CLUSTERED INDEX (.*)|CREATE NONCLUSTERED INDEX (.*)"
Local $sString = "CREATE INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]" & @CRLF & _
"CREATE CLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]" & @CRLF & _
"CREATE NONCLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")