import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "CREATE INDEX (.*)|CREATE CLUSTERED INDEX (.*)|CREATE NONCLUSTERED INDEX (.*)";
final String string = "CREATE INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]\n"
+ "CREATE CLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]\n"
+ "CREATE NONCLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}