import Foundation
let pattern = ##"^[-a-zA-Z0-9#$%'_]+(\.[-a-zA-Z0-9#$%'_]+)*@(([a-zA-Z0-9]{1,2}|[a-zA-Z0-9][-a-zA-Z0-9]+[a-zA-Z0-9])\.)+(?!\d+$)[a-zA-Z0-9]{2,4}$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Aba@example.com
test@test-test.com.com
test.abc-efg'@test-test.com.com.01111co
simple@example.com
very.common@example.com
other.email-with-hyphen@example.com
fully-qualified-domain@example.com
example-indeed@strange-example.com
example@s.example
Abc.example.com
A@b@c@example.com
just"not"right@example.com
this is"not\allowed@example.com
1234567890123456789012345678901234567890123456789012345678901234+x@example.com
john..doe@example.com
john.doe@example..com
test@-test.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)