import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[-a-zA-Z0-9#$%'_]+(\\.[-a-zA-Z0-9#$%'_]+)*@(([a-zA-Z0-9]{1,2}|[a-zA-Z0-9][-a-zA-Z0-9]+[a-zA-Z0-9])\\.)+(?!\\d+$)[a-zA-Z0-9]{2,4}$";
final String string = "Aba@example.com\n"
+ "test@test-test.com.com\n"
+ "test.abc-efg'@test-test.com.com.01111co\n"
+ "simple@example.com\n"
+ "very.common@example.com\n"
+ "other.email-with-hyphen@example.com\n"
+ "fully-qualified-domain@example.com\n"
+ "example-indeed@strange-example.com\n"
+ "example@s.example\n\n"
+ "Abc.example.com\n"
+ "A@b@c@example.com\n"
+ "just\"not\"right@example.com\n"
+ "this is\"not\\allowed@example.com\n"
+ "1234567890123456789012345678901234567890123456789012345678901234+x@example.com\n"
+ "john..doe@example.com\n"
+ "john.doe@example..com\n\n"
+ "test@-test.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}