re = /^[-a-zA-Z0-9#$%'_]+(\.[-a-zA-Z0-9#$%'_]+)*@(([a-zA-Z0-9]{1,2}|[a-zA-Z0-9][-a-zA-Z0-9]+[a-zA-Z0-9])\.)+(?!\d+$)[a-zA-Z0-9]{2,4}$/m
str = 'Aba@example.com
test@test-test.com.com
test.abc-efg\'@test-test.com.com.01111co
simple@example.com
very.common@example.com
other.email-with-hyphen@example.com
fully-qualified-domain@example.com
example-indeed@strange-example.com
example@s.example
Abc.example.com
A@b@c@example.com
just"not"right@example.com
this is"not\\allowed@example.com
1234567890123456789012345678901234567890123456789012345678901234+x@example.com
john..doe@example.com
john.doe@example..com
test@-test.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end