use strict;
my $str = 'Valid cases are green:
PARAMETER_NAME
HELLO_WORLD
hello_word
_new_
_999_
_asdkj123123123asdasd12312312312
_I_am_a_32_characters_long_name
__hello
_____
Invalid cases are not green:
9asdaudqwudhquwdhquwd
_I_am_a_33_characters_long_string
Valid SAS names:
First character is an underscore or an English letter
Followed by any combination of underscores, English letters and numbers
Max 32 characters long';
my $regex = qr/^((?:[_a-z])\w{0,31})\s*$|^.*$/imp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";