import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[_a-z])\\w{0,31})\\s*$|^.*$";
final String string = "Valid cases are green:\n"
+ "PARAMETER_NAME\n"
+ "HELLO_WORLD\n"
+ "hello_word\n"
+ "_new_\n"
+ "_999_\n"
+ "_asdkj123123123asdasd12312312312\n"
+ "_I_am_a_32_characters_long_name\n"
+ "__hello\n"
+ "_____\n\n"
+ "Invalid cases are not green:\n"
+ "9asdaudqwudhquwdhquwd\n"
+ "_I_am_a_33_characters_long_string\n\n\n"
+ "Valid SAS names:\n"
+ "First character is an underscore or an English letter\n"
+ "Followed by any combination of underscores, English letters and numbers\n"
+ "Max 32 characters long";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}