import Foundation
let pattern = #"(Armor.)([a-zA-Z]+)(, Surface.)([a-zA-Z]+)(, name)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
internal CruiserTorpedo(Player owner) : this(owner, "") {
}
internal CruiserTorpedo(string name) : base("Torpedo Cruiser",
new UnitDimensions(4),
new List<Weapon> { new ShipGunSmall(0, 0), new ShipGunSmall(0, 1), new TorpedoTube(0, 2), new AAAGun(0, 3) },
Armor.Light, Surface.Water, name) {
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4, 1$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)