import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Armor.)([a-zA-Z]+)(, Surface.)([a-zA-Z]+)(, name)";
final String string = "internal CruiserTorpedo(Player owner) : this(owner, \"\") {\n"
+ " }\n\n"
+ " internal CruiserTorpedo(string name) : base(\"Torpedo Cruiser\",\n"
+ " new UnitDimensions(4),\n"
+ " new List<Weapon> { new ShipGunSmall(0, 0), new ShipGunSmall(0, 1), new TorpedoTube(0, 2), new AAAGun(0, 3) },\n"
+ " Armor.Light, Surface.Water, name) {\n"
+ " }";
final String subst = "$1$2$3$4, 1$5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}