re = /(Armor.)([a-zA-Z]+)(, Surface.)([a-zA-Z]+)(, name)/
str = 'internal CruiserTorpedo(Player owner) : this(owner, "") {
}
internal CruiserTorpedo(string name) : base("Torpedo Cruiser",
new UnitDimensions(4),
new List<Weapon> { new ShipGunSmall(0, 0), new ShipGunSmall(0, 1), new TorpedoTube(0, 2), new AAAGun(0, 3) },
Armor.Light, Surface.Water, name) {
}'
subst = '$1$2$3$4, 1$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result