$re = '/(namespace FeedStore\.Stores\.EF\.Entities\.Master)(\r\n|\n)({)(\r\n|\n)\s+(public partial class )\s*(\w+)/m';
$str = 'using System;
using System.Collections.Generic;
#nullable disable
namespace FeedStore.Stores.EF.Entities.Master
{
public partial class Admin
{
public int Id { get; set; }
public string Name { get; set; }
public string Alias { get; set; }
public int TenantId { get; set; }
public DateTime Created { get; set; }
public string CreatedBy { get; set; }
public DateTime? Modified { get; set; }
public string ModifiedBy { get; set; }
}
}
';
$subst = "using FeedStore.Stores.EF.Contracts;\r\n\r\n$1$2$3$4\t$5$6 : IAuditableModified, IAuditableAdded";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;