import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(namespace FeedStore\\.Stores\\.EF\\.Entities\\.Master)(\\r\\n|\\n)(\\{)(\\r\\n|\\n)\\s+(public partial class )\\s*(\\w+)";
final String string = "using System;\n"
+ "using System.Collections.Generic;\n\n"
+ "#nullable disable\n\n"
+ "namespace FeedStore.Stores.EF.Entities.Master\n"
+ "{\n"
+ " public partial class Admin\n"
+ " {\n"
+ " public int Id { get; set; }\n"
+ " public string Name { get; set; }\n"
+ " public string Alias { get; set; }\n"
+ " public int TenantId { get; set; }\n"
+ " public DateTime Created { get; set; }\n"
+ " public string CreatedBy { get; set; }\n"
+ " public DateTime? Modified { get; set; }\n"
+ " public string ModifiedBy { get; set; }\n"
+ " }\n"
+ "}\n";
final String subst = "using FeedStore.Stores.EF.Contracts;\\r\\n\\r\\n$1$2$3$4\\t$5$6 : IAuditableModified, IAuditableAdded";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}