const regex = /(namespace FeedStore\.Stores\.EF\.Entities\.Master)(\r\n|\n)({)(\r\n|\n)\s+(public partial class )\s*(\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(namespace FeedStore\\.Stores\\.EF\\.Entities\\.Master)(\\r\\n|\\n)({)(\\r\\n|\\n)\\s+(public partial class )\\s*(\\w+)', 'gm')
const str = `using System;
using System.Collections.Generic;
#nullable disable
namespace FeedStore.Stores.EF.Entities.Master
{
public partial class Admin
{
public int Id { get; set; }
public string Name { get; set; }
public string Alias { get; set; }
public int TenantId { get; set; }
public DateTime Created { get; set; }
public string CreatedBy { get; set; }
public DateTime? Modified { get; set; }
public string ModifiedBy { get; set; }
}
}
`;
const subst = `using FeedStore.Stores.EF.Contracts;\r\n\r\n$1$2$3$4\t$5$6 : IAuditableModified, IAuditableAdded`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);