import Foundation
let pattern = #"SensorId=(?<sensorId>[^ ]+).*Type=(?<type>[^ ]+).*Unit=(?<unit>[^ ]+).*Granularity=(?<granularity>[^ ]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"SensorId=11960_P2 Description=DMC 8 - #10 - Pressao VRP 1 (R Sul) Type=P Unit=Bar Granularity=15 SensorLocationRowId=90 Rmse= EpanetId= "##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)