$re = '/SensorId=(?<sensorId>[^ ]+).*Type=(?<type>[^ ]+).*Unit=(?<unit>[^ ]+).*Granularity=(?<granularity>[^ ]+)/m';
$str = 'SensorId=11960_P2 Description=DMC 8 - #10 - Pressao VRP 1 (R Sul) Type=P Unit=Bar Granularity=15 SensorLocationRowId=90 Rmse= EpanetId= ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);