package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)SensorId=(?<sensorId>[^ ]+).*Type=(?<type>[^ ]+).*Unit=(?<unit>[^ ]+).*Granularity=(?<granularity>[^ ]+)`)
var str = `SensorId=11960_P2 Description=DMC 8 - #10 - Pressao VRP 1 (R Sul) Type=P Unit=Bar Granularity=15 SensorLocationRowId=90 Rmse= EpanetId= `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}