import Foundation
let pattern = #"(^\|(\s*[A-Z][A-Z_]*\s*\|)+\s*$)\r?\n(^\|([\s-]+\|)+\s*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Which SQL query will help you fetch the department ID and department name for departments where the number of employees exceeds 10?
| EMP_ID | F_NAME | L_NAME | SALARY | DEPT_ID_DEP |
| --- | --- | --- | --- | --- |
| 1 | John | Doe | 60000 | 101 |
| 2 | Jane | Smith | 75000 | 102 |
| 3 | Emily | Davis | 80000 | 101 |
| 4 | Michael | Johnson | 65000 | 103 |
| DEP_ID | DEP_NAME | MANAGER_ID | LOCATION_ID |
| --- | --- | --- | --- |
| 101 | IT | 10 | L0001 |
| 102 | HR | 20 | L0002 |
| 103 | Finance | 30 | L0003 |
| 104 | Marketing | 40 | L0004 |
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)