# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\|(\s*[A-Z][A-Z_]*\s*\|)+\s*$)\r?\n(^\|([\s-]+\|)+\s*$)"
test_str = ("Which SQL query will help you fetch the department ID and department name for departments where the number of employees exceeds 10?\n"
"| EMP_ID | F_NAME | L_NAME | SALARY | DEPT_ID_DEP |\n"
"| --- | --- | --- | --- | --- |\n"
"| 1 | John | Doe | 60000 | 101 |\n"
"| 2 | Jane | Smith | 75000 | 102 |\n"
"| 3 | Emily | Davis | 80000 | 101 |\n"
"| 4 | Michael | Johnson | 65000 | 103 |\n"
"| DEP_ID | DEP_NAME | MANAGER_ID | LOCATION_ID |\n"
"| --- | --- | --- | --- |\n"
"| 101 | IT | 10 | L0001 |\n"
"| 102 | HR | 20 | L0002 |\n"
"| 103 | Finance | 30 | L0003 |\n"
"| 104 | Marketing | 40 | L0004 |")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.