const regex = /(^\|(\s*[A-Z][A-Z_]*\s*\|)+\s*$)\r?\n(^\|([\s-]+\|)+\s*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\|(\\s*[A-Z][A-Z_]*\\s*\\|)+\\s*$)\\r?\\n(^\\|([\\s-]+\\|)+\\s*$)', 'gm')
const str = `Which SQL query will help you fetch the department ID and department name for departments where the number of employees exceeds 10?
| EMP_ID | F_NAME | L_NAME | SALARY | DEPT_ID_DEP |
| --- | --- | --- | --- | --- |
| 1 | John | Doe | 60000 | 101 |
| 2 | Jane | Smith | 75000 | 102 |
| 3 | Emily | Davis | 80000 | 101 |
| 4 | Michael | Johnson | 65000 | 103 |
| DEP_ID | DEP_NAME | MANAGER_ID | LOCATION_ID |
| --- | --- | --- | --- |
| 101 | IT | 10 | L0001 |
| 102 | HR | 20 | L0002 |
| 103 | Finance | 30 | L0003 |
| 104 | Marketing | 40 | L0004 |`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}