re = /(01\d+(?=17)|01\d+(?=10\w))?(17\d+)?(10\w+|\x1D10\w+)/
str = '0150010DR17
0150010DR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end