$re = '/(01\d+(?=17)|01\d+(?=10\w))?(17\d+)?(10\w+|\x1D10\w+)/';
$str = '0150010DR17
0150010DR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);