const regex = /(01\d+(?=17)|01\d+(?=10\w))?(17\d+)?(10\w+|\x1D10\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(01\\d+(?=17)|01\\d+(?=10\\w))?(17\\d+)?(10\\w+|\\x1D10\\w+)', 'g')
const str = `0150010DR17
0150010DR`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}