re = /Social:(?<cRegexGroupsName>.*?)\s[^\W]{2}\s/m
str = 'Dirección Provincial de: LEONUnidad de Recaudación Ejecutiva nº: 24/01 NIF/CIF: 009810075T Apellidos y nombre/R.Social: CLAUDIA RODRIGUEZ VEGA JOSE VICENTE AV CARDENAL LANDAZURI 7 BJ Domicilio: Tipo/Ident.: 10 24108755670 Régimen: 0111Localidad: 24003 LEON Nº Expediente: 24 01 17 00130817Importe deuda pendiente: 0,00 Nº Documento: 24 01 459 20 012724485NOTIFICACIÓN A LA ENTIDAD PAGADORA DEL LEVANTAMIENTO DE EMBARGO DE DERECHOSECONÓMICOS A
^((?:\\S+\\s+){2}\\S+).*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end