const regex = /Social:(?<cRegexGroupsName>.*?)\s[^\W]{2}\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Social:(?<cRegexGroupsName>.*?)\\s[^\\W]{2}\\s', 'gm')
const str = `Dirección Provincial de: LEONUnidad de Recaudación Ejecutiva nº: 24/01 NIF/CIF: 009810075T Apellidos y nombre/R.Social: CLAUDIA RODRIGUEZ VEGA JOSE VICENTE AV CARDENAL LANDAZURI 7 BJ Domicilio: Tipo/Ident.: 10 24108755670 Régimen: 0111Localidad: 24003 LEON Nº Expediente: 24 01 17 00130817Importe deuda pendiente: 0,00 Nº Documento: 24 01 459 20 012724485NOTIFICACIÓN A LA ENTIDAD PAGADORA DEL LEVANTAMIENTO DE EMBARGO DE DERECHOSECONÓMICOS A
^((?:\\S+\\s+){2}\\S+).*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}