import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Social:(?<cRegexGroupsName>.*?)\\s[^\\W]{2}\\s";
final String string = "Dirección Provincial de: LEONUnidad de Recaudación Ejecutiva nº: 24/01 NIF/CIF: 009810075T Apellidos y nombre/R.Social: CLAUDIA RODRIGUEZ VEGA JOSE VICENTE AV CARDENAL LANDAZURI 7 BJ Domicilio: Tipo/Ident.: 10 24108755670 Régimen: 0111Localidad: 24003 LEON Nº Expediente: 24 01 17 00130817Importe deuda pendiente: 0,00 Nº Documento: 24 01 459 20 012724485NOTIFICACIÓN A LA ENTIDAD PAGADORA DEL LEVANTAMIENTO DE EMBARGO DE DERECHOSECONÓMICOS A \n\n"
+ "^((?:\\S+\\s+){2}\\S+).*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}