$re = '/([\( ,]*[^a-z^A-z])(word)([^a-z^A-z])/m';
$str = 'void CANopenDownload( word hans, word, fritz, dword nodeId, dword index, dword subIndex, qword data, dword dataSize, dword blockMode, dword errCode[] ); // form 1
void CANopenDownload( dword nodeId, dword index, dword subIndex, char[] data, dword dataSize, dword blockMode, dword errCode[] ); // form 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);