const regex = /([\( ,]*[^a-z^A-z])(word)([^a-z^A-z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\( ,]*[^a-z^A-z])(word)([^a-z^A-z])', 'gm')
const str = `void CANopenDownload( word hans, word, fritz, dword nodeId, dword index, dword subIndex, qword data, dword dataSize, dword blockMode, dword errCode[] ); // form 1
void CANopenDownload( dword nodeId, dword index, dword subIndex, char[] data, dword dataSize, dword blockMode, dword errCode[] ); // form 2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}