package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\( ,]*[^a-z^A-z])(word)([^a-z^A-z])`)
var str = `void CANopenDownload( word hans, word, fritz, dword nodeId, dword index, dword subIndex, qword data, dword dataSize, dword blockMode, dword errCode[] ); // form 1
void CANopenDownload( dword nodeId, dword index, dword subIndex, char[] data, dword dataSize, dword blockMode, dword errCode[] ); // form 2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}