const regex = new RegExp('^(?:подлесок:?+)(?:[ ]*+(?<TS1>[а-я]{1,4}|\\d+)(?=[ ,+]|$))?+(?:[, +]*+(?<TS2>[а-я]{1,4}|\\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS3>[а-я]{1,4}|\\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS4>[а-я]{1,4}|(\\d+))(?=[, +]|$))?+(?:[, +]*+(?<TS5>[а-я]{1,4}|\\d+)(?=[, +]|$))?+(?:,?[ ]*+(?<DENSITY>средний|густой|редкий|ср\\.густ|средней|редкой))?.*+$', 'gmiu')
const str = `подлесок: Р КС ОЛК СР.ГУСТ
подлесок: Р КУЛ СРЕДНИЙ
подлесок: ИВК Р СРЕДНИЙ
подлесок: КУЛ ЛЩ СРЕДНИЙ
подлесок: Ч,Кл,Лщ средний
подлесок: Ч,Кл,Лщ густой
подлесок: ЛЩ ЛС КЛ средний
подлесок: РН СП густой
подлесок: СП РН Ч густой
подлесок: КЛ КС РЕДКИЙ
подлесок: Лщ редкий
подлесок: БРК КРЛ Р
подлесок ЛЩ+КРЛ+ИВК редкий
подлесок ЛЩ+КРЛ редкий`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}