#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)^(?:подлесок:?+)(?:[ ]*+(?<TS1>[а-я]{1,4}|\d+)(?=[ ,+]|$))?+(?:[, +]*+(?<TS2>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS3>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS4>[а-я]{1,4}|(\d+))(?=[, +]|$))?+(?:[, +]*+(?<TS5>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:,?[ ]*+(?<DENSITY>средний|густой|редкий|ср\.густ|средней|редкой))?.*+$"
Local $sString = "подлесок: Р КС ОЛК СР.ГУСТ" & @CRLF & _
"подлесок: Р КУЛ СРЕДНИЙ" & @CRLF & _
"подлесок: ИВК Р СРЕДНИЙ" & @CRLF & _
"подлесок: КУЛ ЛЩ СРЕДНИЙ" & @CRLF & _
"подлесок: Ч,Кл,Лщ средний " & @CRLF & _
"подлесок: Ч,Кл,Лщ густой " & @CRLF & _
"подлесок: ЛЩ ЛС КЛ средний" & @CRLF & _
"подлесок: РН СП густой" & @CRLF & _
"подлесок: СП РН Ч густой" & @CRLF & _
"подлесок: КЛ КС РЕДКИЙ" & @CRLF & _
"подлесок: Лщ редкий" & @CRLF & _
"подлесок: БРК КРЛ Р " & @CRLF & _
"подлесок ЛЩ+КРЛ+ИВК редкий" & @CRLF & _
"подлесок ЛЩ+КРЛ редкий"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")