import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:подлесок:?+)(?:[ ]*+(?<TS1>[а-я]{1,4}|\\d+)(?=[ ,+]|$))?+(?:[, +]*+(?<TS2>[а-я]{1,4}|\\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS3>[а-я]{1,4}|\\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS4>[а-я]{1,4}|(\\d+))(?=[, +]|$))?+(?:[, +]*+(?<TS5>[а-я]{1,4}|\\d+)(?=[, +]|$))?+(?:,?[ ]*+(?<DENSITY>средний|густой|редкий|ср\\.густ|средней|редкой))?.*+$";
final String string = "подлесок: Р КС ОЛК СР.ГУСТ\n"
+ "подлесок: Р КУЛ СРЕДНИЙ\n"
+ "подлесок: ИВК Р СРЕДНИЙ\n"
+ "подлесок: КУЛ ЛЩ СРЕДНИЙ\n"
+ "подлесок: Ч,Кл,Лщ средний \n"
+ "подлесок: Ч,Кл,Лщ густой \n"
+ "подлесок: ЛЩ ЛС КЛ средний\n"
+ "подлесок: РН СП густой\n"
+ "подлесок: СП РН Ч густой\n"
+ "подлесок: КЛ КС РЕДКИЙ\n"
+ "подлесок: Лщ редкий\n"
+ "подлесок: БРК КРЛ Р \n"
+ "подлесок ЛЩ+КРЛ+ИВК редкий\n"
+ "подлесок ЛЩ+КРЛ редкий";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}