// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[\x00-\x1F\x7F<>:"\/\\|?*]"#).unwrap();
let string = "match newline
match tab
does not match space
mactch char \"*/:<>?\\|";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}