package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\x00-\x1F\x7F<>:"\/\\|?*]`)
var str = `match newline
match tab
does not match space
mactch char "*/:<>?\|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}