$re = '/[\x00-\x1F\x7F<>:"\/\\\\|?*]/m';
$str = 'match newline
match tab
does not match space
mactch char "*/:<>?\\|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);