# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(Primary|Secondary|Tertiary).Gene:.([A-Z]|[a-z])+ \(1\)"
test_str = ("1([A-Z]|[a-z])+\n"
"Scroll of Renaming (1) \n"
"Seller: Rogrinus\n\n"
"Expires in: 07 hr, 09 min, 46 sec\n"
"Selling price:\n"
" 200000\n"
" \n"
"1\n"
"Secondary Gene: Loop (Veilspun) (1) \n"
"Seller: Natta\n\n"
"Expires in: 09 hr, 21 min, 47 sec\n"
"Selling price:\n"
" 200000\n"
" \n"
"1\n"
"Primary Gene: Python (1) \n"
"Seller: PlatinumStardust\n\n"
"Expires in: 1 days, 07 hr, 37 min, 50 sec\n"
"Selling price:\n"
" 200000\n"
" \n"
"1\n"
"Primary Gene: Stitched (Veilspun) (1) \n"
"Seller: lizagem\n\n"
"Expires in: 2 days, 11 hr, 07 min, 56 sec\n"
"Selling price:\n"
" 200000\n"
" \n"
"1\n"
"Primary Gene: Stitched (Veilspun) (1) \n"
"Seller: ScarletCyanide\n\n"
"Expires in: 3 days, 06 hr, 31 min, 26 sec\n"
"Selling price:\n"
" 200000\n"
" \n"
"1\n"
"Tertiary Gene: Capsule (Veilspun) (1) \n"
"Seller: forcipiger\n\n"
"Expires in: 4 days, 04 hr, 15 min, 26 sec\n"
"Selling price:\n"
" 200000\n"
" \n"
"1\n"
"Tertiary Gene: Firefly (Veilspun) (1) \n"
"Seller: Pyracantha\n\n"
"Expires in: 4 days, 23 hr, 35 min, 53 sec\n"
"Selling price:\n"
" 200000\n"
" \n"
"1\n"
"Primary Gene: Python (1) \n"
"Seller: sisyo\n\n"
"Expires in: 5 days, 13 hr, 59 min, 20 sec\n"
"Selling price:\n"
" 200000\n"
" \n"
"1\n"
"Tertiary Gene: Squiggle (Banescale) (1) \n"
"Seller: BananaMeteor\n\n"
"Expires in: 5 days, 18 hr, 32 min, 31 sec\n"
"Selling price:\n"
" 200000\n"
" \n"
"1\n"
"Primary Gene: Skink (1) \n"
"Seller: H0ur\n\n"
"Expires in: 6 days, 13 hr, 07 min, 31 sec\n"
"Selling price:\n"
" 200000\n"
" ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.