#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(Primary|Secondary|Tertiary).Gene:.([A-Z]|[a-z])+ \(1\)"
Local $sString = "1([A-Z]|[a-z])+" & @CRLF & _
"Scroll of Renaming (1) " & @CRLF & _
"Seller: Rogrinus" & @CRLF & _
"" & @CRLF & _
"Expires in: 07 hr, 09 min, 46 sec" & @CRLF & _
"Selling price:" & @CRLF & _
" 200000" & @CRLF & _
" " & @CRLF & _
"1" & @CRLF & _
"Secondary Gene: Loop (Veilspun) (1) " & @CRLF & _
"Seller: Natta" & @CRLF & _
"" & @CRLF & _
"Expires in: 09 hr, 21 min, 47 sec" & @CRLF & _
"Selling price:" & @CRLF & _
" 200000" & @CRLF & _
" " & @CRLF & _
"1" & @CRLF & _
"Primary Gene: Python (1) " & @CRLF & _
"Seller: PlatinumStardust" & @CRLF & _
"" & @CRLF & _
"Expires in: 1 days, 07 hr, 37 min, 50 sec" & @CRLF & _
"Selling price:" & @CRLF & _
" 200000" & @CRLF & _
" " & @CRLF & _
"1" & @CRLF & _
"Primary Gene: Stitched (Veilspun) (1) " & @CRLF & _
"Seller: lizagem" & @CRLF & _
"" & @CRLF & _
"Expires in: 2 days, 11 hr, 07 min, 56 sec" & @CRLF & _
"Selling price:" & @CRLF & _
" 200000" & @CRLF & _
" " & @CRLF & _
"1" & @CRLF & _
"Primary Gene: Stitched (Veilspun) (1) " & @CRLF & _
"Seller: ScarletCyanide" & @CRLF & _
"" & @CRLF & _
"Expires in: 3 days, 06 hr, 31 min, 26 sec" & @CRLF & _
"Selling price:" & @CRLF & _
" 200000" & @CRLF & _
" " & @CRLF & _
"1" & @CRLF & _
"Tertiary Gene: Capsule (Veilspun) (1) " & @CRLF & _
"Seller: forcipiger" & @CRLF & _
"" & @CRLF & _
"Expires in: 4 days, 04 hr, 15 min, 26 sec" & @CRLF & _
"Selling price:" & @CRLF & _
" 200000" & @CRLF & _
" " & @CRLF & _
"1" & @CRLF & _
"Tertiary Gene: Firefly (Veilspun) (1) " & @CRLF & _
"Seller: Pyracantha" & @CRLF & _
"" & @CRLF & _
"Expires in: 4 days, 23 hr, 35 min, 53 sec" & @CRLF & _
"Selling price:" & @CRLF & _
" 200000" & @CRLF & _
" " & @CRLF & _
"1" & @CRLF & _
"Primary Gene: Python (1) " & @CRLF & _
"Seller: sisyo" & @CRLF & _
"" & @CRLF & _
"Expires in: 5 days, 13 hr, 59 min, 20 sec" & @CRLF & _
"Selling price:" & @CRLF & _
" 200000" & @CRLF & _
" " & @CRLF & _
"1" & @CRLF & _
"Tertiary Gene: Squiggle (Banescale) (1) " & @CRLF & _
"Seller: BananaMeteor" & @CRLF & _
"" & @CRLF & _
"Expires in: 5 days, 18 hr, 32 min, 31 sec" & @CRLF & _
"Selling price:" & @CRLF & _
" 200000" & @CRLF & _
" " & @CRLF & _
"1" & @CRLF & _
"Primary Gene: Skink (1) " & @CRLF & _
"Seller: H0ur" & @CRLF & _
"" & @CRLF & _
"Expires in: 6 days, 13 hr, 07 min, 31 sec" & @CRLF & _
"Selling price:" & @CRLF & _
" 200000" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")