import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(Primary|Secondary|Tertiary).Gene:.([A-Z]|[a-z])+ \\(1\\)";
final String string = "1([A-Z]|[a-z])+\n"
+ "Scroll of Renaming (1) \n"
+ "Seller: Rogrinus\n\n"
+ "Expires in: 07 hr, 09 min, 46 sec\n"
+ "Selling price:\n"
+ " 200000\n"
+ " \n"
+ "1\n"
+ "Secondary Gene: Loop (Veilspun) (1) \n"
+ "Seller: Natta\n\n"
+ "Expires in: 09 hr, 21 min, 47 sec\n"
+ "Selling price:\n"
+ " 200000\n"
+ " \n"
+ "1\n"
+ "Primary Gene: Python (1) \n"
+ "Seller: PlatinumStardust\n\n"
+ "Expires in: 1 days, 07 hr, 37 min, 50 sec\n"
+ "Selling price:\n"
+ " 200000\n"
+ " \n"
+ "1\n"
+ "Primary Gene: Stitched (Veilspun) (1) \n"
+ "Seller: lizagem\n\n"
+ "Expires in: 2 days, 11 hr, 07 min, 56 sec\n"
+ "Selling price:\n"
+ " 200000\n"
+ " \n"
+ "1\n"
+ "Primary Gene: Stitched (Veilspun) (1) \n"
+ "Seller: ScarletCyanide\n\n"
+ "Expires in: 3 days, 06 hr, 31 min, 26 sec\n"
+ "Selling price:\n"
+ " 200000\n"
+ " \n"
+ "1\n"
+ "Tertiary Gene: Capsule (Veilspun) (1) \n"
+ "Seller: forcipiger\n\n"
+ "Expires in: 4 days, 04 hr, 15 min, 26 sec\n"
+ "Selling price:\n"
+ " 200000\n"
+ " \n"
+ "1\n"
+ "Tertiary Gene: Firefly (Veilspun) (1) \n"
+ "Seller: Pyracantha\n\n"
+ "Expires in: 4 days, 23 hr, 35 min, 53 sec\n"
+ "Selling price:\n"
+ " 200000\n"
+ " \n"
+ "1\n"
+ "Primary Gene: Python (1) \n"
+ "Seller: sisyo\n\n"
+ "Expires in: 5 days, 13 hr, 59 min, 20 sec\n"
+ "Selling price:\n"
+ " 200000\n"
+ " \n"
+ "1\n"
+ "Tertiary Gene: Squiggle (Banescale) (1) \n"
+ "Seller: BananaMeteor\n\n"
+ "Expires in: 5 days, 18 hr, 32 min, 31 sec\n"
+ "Selling price:\n"
+ " 200000\n"
+ " \n"
+ "1\n"
+ "Primary Gene: Skink (1) \n"
+ "Seller: H0ur\n\n"
+ "Expires in: 6 days, 13 hr, 07 min, 31 sec\n"
+ "Selling price:\n"
+ " 200000\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}