$re = '@<url>\s*<loc>[^<]+login.+?</url>\s*@s';
$str = '<url>
<loc>http://review-pref.ru/literatura/49/131/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/folklor/4/178/4/javascript/login</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/literatura/56/65/login/javascript/login/login/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/folklor/4/164/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;