import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<url>\\s*<loc>[^<]+login.+?</url>\\s*";
final String string = "<url>\n"
+ "<loc>http://review-pref.ru/literatura/49/131/</loc>\n"
+ "<changefreq>monthly</changefreq>\n"
+ "<priority>0.3</priority>\n"
+ "</url>\n"
+ "<url>\n"
+ "<loc>http://review-pref.ru/folklor/4/178/4/javascript/login</loc>\n"
+ "<changefreq>monthly</changefreq>\n"
+ "<priority>0.3</priority>\n"
+ "</url>\n"
+ "<url>\n"
+ "<loc>http://review-pref.ru/literatura/56/65/login/javascript/login/login/</loc>\n"
+ "<changefreq>monthly</changefreq>\n"
+ "<priority>0.3</priority>\n"
+ "</url>\n"
+ "<url>\n"
+ "<loc>http://review-pref.ru/folklor/4/164/</loc>\n"
+ "<changefreq>monthly</changefreq>\n"
+ "<priority>0.3</priority>\n"
+ "</url>\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}