package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<url>\s*<loc>[^<]+login.+?</url>\s*`)
var str = `<url>
<loc>http://review-pref.ru/literatura/49/131/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/folklor/4/178/4/javascript/login</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/literatura/56/65/login/javascript/login/login/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
<url>
<loc>http://review-pref.ru/folklor/4/164/</loc>
<changefreq>monthly</changefreq>
<priority>0.3</priority>
</url>
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}