re = /((http[s]?\:\/\/)|(ww(w|\d{1,3})\.))/m
str = 'https://
www.
ww1.
ww11.
ww234.
ww12345.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end