#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((http[s]?\:\/\/)|(ww(w|\d{1,3})\.))"
Local $sString = "https://" & @CRLF & _
"" & @CRLF & _
"www." & @CRLF & _
"ww1." & @CRLF & _
"ww11." & @CRLF & _
"ww234." & @CRLF & _
"ww12345." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")