$re = '/((http[s]?\:\/\/)|(ww(w|\d{1,3})\.))/m';
$str = 'https://
www.
ww1.
ww11.
ww234.
ww12345.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);