const regex = /\S+\[v=\"(timeSeries)-(\w+)\",g=\"(\w+)\",p=\"(\S+)\"\]\S+array\[(\d+)\]\/(\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+\\[v=\\"(timeSeries)-(\\w+)\\",g=\\"(\\w+)\\",p=\\"(\\S+)\\"\\]\\S+array\\[(\\d+)\\]\\\/(\\S+)', 'g')
const str = `root/12-825-ReturnAndStatsCompositeAPI[v="timeSeries-return",g="timeSeries",p="{"rollingPeriod":"1Y","numberOfPeriods":"5","asOfDate":"2016-12-31","startDate":"2011-12-31","frequency":"1Y"}"]/data/share_classes/array[1]/returns_series/returns/array[1]/net/cumulative
root/2-825-ReturnAndStatsCompositeAPI[v="timeSeries-benchmark",g="timeSeries",p="{"rollingPeriod":"1Y","column":"column","numberOfPeriods":"5","asOfDate":"2016-12-31","startDate":"2011-12-31","frequency":"1Y"}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/returns_series/returns/array[1]/gross/annualized
root/2-825-ReturnAndStatsCompositeAPI[v="timeSeries-benchmark",g="timeSeries",p="{"rollingPeriod":"1Y","column":"column","numberOfPeriods":"5","asOfDate":"2016-12-31","startDate":"2011-12-31","frequency":"1Y"}"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_series/relative/gross/array[1]/excess_return
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}