import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+\\[v=\\\"(timeSeries)-(\\w+)\\\",g=\\\"(\\w+)\\\",p=\\\"(\\S+)\\\"\\]\\S+array\\[(\\d+)\\]\\/(\\S+)";
final String string = "root/12-825-ReturnAndStatsCompositeAPI[v=\"timeSeries-return\",g=\"timeSeries\",p=\"{\"rollingPeriod\":\"1Y\",\"numberOfPeriods\":\"5\",\"asOfDate\":\"2016-12-31\",\"startDate\":\"2011-12-31\",\"frequency\":\"1Y\"}\"]/data/share_classes/array[1]/returns_series/returns/array[1]/net/cumulative\n\n"
+ "root/2-825-ReturnAndStatsCompositeAPI[v=\"timeSeries-benchmark\",g=\"timeSeries\",p=\"{\"rollingPeriod\":\"1Y\",\"column\":\"column\",\"numberOfPeriods\":\"5\",\"asOfDate\":\"2016-12-31\",\"startDate\":\"2011-12-31\",\"frequency\":\"1Y\"}\"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/returns_series/returns/array[1]/gross/annualized\n\n"
+ "root/2-825-ReturnAndStatsCompositeAPI[v=\"timeSeries-benchmark\",g=\"timeSeries\",p=\"{\"rollingPeriod\":\"1Y\",\"column\":\"column\",\"numberOfPeriods\":\"5\",\"asOfDate\":\"2016-12-31\",\"startDate\":\"2011-12-31\",\"frequency\":\"1Y\"}\"]/data/share_classes/array[1]/benchmark_types/benchmark_types_breakdown/array[3]/mpt_statistics_series/relative/gross/array[1]/excess_return\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}